Python bindings for the Message Passing Interface standard

MPI for Python (mpi4py) provides bindings of the Message Passing Interface (MPI) standard for the Python programming language, allowing any Python program to exploit multiple processors.

mpi4py is constructed on top of the MPI-1/MPI-2 specification and provides an object oriented interface which closely follows MPI-2 C++ bindings. It supports point-to-point and collective communications of any picklable Python object as well as optimized communications of Python objects (such as NumPy arrays) that expose a buffer interface.


Packagepython-mpi4py
Version3.1.4 (history)
Channelguix
Definitiongnu/packages/mpi.scm
Build statusview 🚧
Home pagehttps://github.com/mpi4py/mpi4py
SourceSource code archival status at Software Heritage.
Installation command
guix install python-mpi4py