Portable Computing Language (pocl), an OpenCL implementation

Pocl is a portable implementation of the OpenCL standard (1.2 with some 2.0 features supported). This project seeks to improve performance portability of OpenCL programs with the kernel compiler and the task run-time, reducing the need for target-dependent manual optimizations.

pocl uses Clang as an OpenCL C frontend and LLVM for kernel compiler implementation, and as a portability layer. Thus, if your desired target has an LLVM backend, it should be able to get OpenCL support easily by using pocl.


Packagepocl
Version3.1 (history)
Channelguix
Definitiongnu/packages/opencl.scm
Build statusview 🚧
Home pagehttp://portablecl.org/
SourceSource code archival status at Software Heritage.
Installation command
guix install pocl