OpenCL framework for Intel GPUs

Beignet is an implementation of the OpenCL specification. This code base contains the code to run OpenCL programs on Intel GPUs---IvyBridge, Haswell, Skylake, Apollolake, etc. It defines and implements the OpenCL host functions required to initialize the device, create the command queues, the kernels and the programs, and run them on the GPU. The code also contains a back-end for the LLVM compiler framework.


Packagebeignet
Version1.3.2 (history)
Channelguix
Definitiongnu/packages/opencl.scm
Build statusview 🚧
Home pagehttps://wiki.freedesktop.org/www/Software/Beignet/
SourceSource code archival status at Software Heritage.
Installation command
guix install beignet